BVI ini sangat berguna jika kita menginginkan router yang bisa bertindak seperti switch

misalkan ada case
CASE 1
———–
sebelumnya ada 3 router tetapi karena ada kebijakan baru yang R1 dan R3 hanya memiliki 1 segmen IP saja, sebenarnya bisa aja kita lepas R2 tetapi ternyata jarak R1-R2 & jarak R2-R3 masing masing 90m jadinya tidak memungkinkan untuk dilepas routernya karena jika di lepas akan ada tarikan kabel dengan panjang 180m dan ini tidak memungkinkan jika menggunakan kabel UTP harus menggunakan fiber optic, jadi solusinya kita bisa menerapkan bridging

case 1

pasang IP di R1

interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
no shut
end

pasang IP di R3

interface FastEthernet0/0
ip address 192.168.10.2 255.255.255.0
no shut
end

selanjutnya tinggal aktifkan Bridging di R2

bridge irb
bridge 1 protocol ieee
interface range FastEthernet0/0 – 1
bridge-group 1
no shut
end

perintah “bridge irb” berfungsi untuk mengaktifkan fitur bridging di router
perintah “bridge 1 protocol ieee” berfungsi untuk mengaktifkan spanning-tree, karena router sudah berfungsi sebagai switch jadi perlu ada STP

selanjutnya tinggal di ping IP dari R1 ke R3

R1#ping 192.168.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/88/216 ms
R1#

melihat anggota yang ikut bridge

R2#sh bridge group

Bridge Group 1 is running the IEEE compatible Spanning Tree protocol

Port 4 (FastEthernet0/0) of bridge group 1 is forwarding
Port 5 (FastEthernet0/1) of bridge group 1 is forwarding

R2#

karena sekarang router sudah bertindak sebagai switch kita lihat spanning-tree

R2#sh spanning-tree brief

Bridge group 1
Spanning tree enabled protocol ieee
Root ID Priority 32768
Address c001.0814.0000
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768
Address c001.0814.0000
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Designated
Name Port ID Prio Cost Sts Cost Bridge ID Port ID
——————– ——- —- —– — —– ——————– ——-
FastEthernet0/0 128.4 128 100 FWD 0 32768 c001.0814.0000 128.4
FastEthernet0/1 128.5 128 100 FWD 0 32768 c001.0814.0000 128.5

R2#

CASE 2
——
ada beberapa cabang yang saling komunikasi dengan menggunakan layanan metro-e atau layanan apapun di layer 2, karena semua IP jadi 1 segmen lalu bagaimana caranya jika ada salah 1 cabang ingin menggunakan redundant link ? yaps, jawabannya bisa menggunakan BVI, berikut ini solusinya, saya akan lampirkan case awalnya terlebih dahulu

gambar topologi awal

case 2 awal

dari topologi di atas dibuat agar semua bisa saling ping ke interface loopback, bebas mo menggunakan routing protokol apa, karena saya tidak membahas bagaimana caranya agar bisa ping ke semua interface loopback di semua router, pembahasan itu ada di buku saya yang bisa di dapatkan di link ini atau bisa kontak saya di email danu.wiyoto[at]bestpath-network.com atau mdwiyoto[at]gmail.com

lalu bagaimana jika cabang ingin memiliki link backup ?
gambar topologi link backup di cabang

case 2 backup

terlihat sekarang R1 sudah memiliki 2 link, yang salah satu link akan di blok

jika sudah dikonfig selanjutnya tinggal tambahin untuk BVI saja di router yang menggunakan link backup, di gambar diatas yang memiliki link backup adalah R1 dan R1 yang akan kita konfig BVI

bridge irb
bridge 1 protocol ieee
bridge 1 route ip
!
interface FastEthernet0/0
no ip address
bridge-group 1
!
interface FastEthernet0/1
no ip address
bridge-group 1
!
interface BVI1
ip address 192.168.10.1 255.255.255.0
!
bridge 1 priority 1

perintah “bridge 1 route ip” berfungsi untuk mengaktifkan fungsi routing protokol

ping dari R1 ke semua ip loopback di R2 & R3

R1#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/63/128 ms
R1#
R1#
R1#ping 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/65/156 ms
R1#

ping berhasil

perintah “bridge 1 priority 1″ menjadikan R1 ini menjadi root bridge

R1#sh spanning-tree bri

Bridge group 1
Spanning tree enabled protocol ieee
Root ID Priority 1
Address c000.195c.0000
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 1
Address c000.195c.0000
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Designated
Name Port ID Prio Cost Sts Cost Bridge ID Port ID
——————– ——- —- —– — —– ——————– ——-
FastEthernet0/0 128.4 128 100 FWD 0 1 c000.195c.0000 124.5
FastEthernet0/1 124.5 128 100 BLK 0 1 c000.195c.0000 124.5

R1#

terlihat router sudah menjadi root bridge dan int fa0/1 di blok sedangkan int fa0/0 status forwarding, itu karena STP akan memilih port id yang terendah karena priority di port sama-sama 128 jadi port id yang terendah yang diambil, jika ingin dibalik int fa0/0 menjadi BLK dan int fa0/1 menjadi FWD maka kecilkan priority di fa0/1 atau naikkan nilai priority di fa0/0, disini saya akan menurunkan priority di fa0/1

R1(config-if)#bridge-group 1 priority 127
Priority in increments of 4 is required

R1(config-if)#bridge-group 1 priority 124

nilai priority yang di ubah harus kelipatan 4, terbukti diturunkan ke 127 si router menolak, akirnya diturunkan menjadi 124, selanjutnya cek STP apakah sudah berubah

R1(config-if)#
*Mar 1 00:10:50.715: %OSPF-5-ADJCHG: Process 10, Nbr 3.3.3.3 on BVI1 from FULL to DOWN, Neighbor Down: Dead timer expired
*Mar 1 00:10:50.943: %OSPF-5-ADJCHG: Process 10, Nbr 2.2.2.2 on BVI1 from FULL to DOWN, Neighbor Down: Dead timer expired
*Mar 1 00:10:50.979: %OSPF-5-ADJCHG: Process 10, Nbr 3.3.3.3 on BVI1 from LOADING to FULL, Loading Done
*Mar 1 00:10:51.223: %OSPF-5-ADJCHG: Process 10, Nbr 2.2.2.2 on BVI1 from LOADING to FULL, Loading Done
R1(config-if)#
R1(config-if)#do sh span bri

Bridge group 1
Spanning tree enabled protocol ieee
Root ID Priority 1
Address c000.195c.0000
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 1
Address c000.195c.0000
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Designated
Name Port ID Prio Cost Sts Cost Bridge ID Port ID
——————– ——- —- —– — —– ——————– ——-
FastEthernet0/0 128.4 128 100 BLK 0 1 c000.195c.0000 124.5
FastEthernet0/1 124.5 124 100 FWD 0 1 c000.195c.0000 124.5

R1(config-if)#

ternyata pas ada perubahan priority di port terjadi kalkulasi ulang di OSPF-nya, sekarang port yang forwarding sudah sesuai keinginan

semoga bermanfaat

Salam,
Danu Wiyoto

*ditulis dimalam sesudah malam memperingati hari Pale Entin, dan case ini ada di real case yang saya hadapi
terimakasih saya kepada mas Jodi yang telah memberikan solusi BVI ini dan juga ForTIMa dimana saya curcol pertanyaan ini ke group

One thought on “Bridge Virtual Interface (BVI)

Leave a comment

Your email address will not be published. Required fields are marked *

18 + 15 =