melanjutkan lab kita di Workbook CCNA Best-Path tentang DHCP, di workbook berisi tentang bagaimana suatu host bisa mendapatkan alamat IP, alamat IP yang diberikan bisa bersifat random, agar alamat IP tidak berubah-ubah sebaiknya dilakukan reservasi dari alamat IP tersebut mari kita mainkan caranya

kita menggunakan topologi

dhcp gns3

pada topologi di atas untuk mensimulasikan DHCP Client kita menggunakan router, basic config sebelum menerapkan DHCP di R1, isi konfig hanya memasang IP saja

R1#
!
interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
no shut
end

dan dibawah ini basic config R2 yang isi konfignya hanya menjadikan port yang ke arah DHCP Server menjadi port yang bisa menerima DHCP

R2#
!
interface FastEthernet0/0
ip address dhcp
no shut
end

 

sebelum di konfig di DHCP Server ada baiknya menyiapkan mac-address dari host, kita anggap mac-address host adalah c001.0e10.0000 dan mac-address selanjutnya akan kita iket (binding) dengan ip address yang diinginkan

!

selanjutnya ke R1 yang sebagai DHCP Server, pasang DHCP pool dan tetapkan alamat IPnya

R1(config)#ip dhcp pool POLBP
R1(dhcp-config)# host 192.168.10.2 255.255.255.0
R1(dhcp-config)#?
DHCP pool configuration commands:
accounting                Send Accounting Start/Stop messages
bootfile                          Boot file name
class                                Specify a DHCP class
client-identifier            Client identifier
client-name                   Client name
default-router               Default routers
dns-server                      DNS servers
domain-name                Domain name
exit                                   Exit from DHCP pool configuration mode
hardware-address         Client hardware address
host                                  Client IP address and mask
import                              Programatically importing DHCP option parameters
lease                                  Address lease time
netbios-name-server     NetBIOS (WINS) name servers
netbios-node-type          NetBIOS node type
network                            Network number and mask
next-server                     Next server in boot process
no                                     Negate a command or set its defaults
option                             Raw DHCP options
origin                              Configure the origin of the pool
relay                                Function as a DHCP relay
server                             Configure the server ID option value
subnet                            Subnet allocation commands
update                           Dynamic updates
utilization                 Configure various utilization parameters
vrf                                  Associate this pool with a VRF

R1(dhcp-config)#

terlihat di atas yang terlihat perintah cocok sepertinya menggunakan hardware-address untuk binding mac-address dengan alamat ip, selanjutnya kita gunakan perintah tersebut

R1(dhcp-config)#hardware-address c001.0e10.0000

selanjutnya kita lihat dari host DHCP Client apakah sudah mendapatkan IP apa belum, sebelum melihat di host ada baiknya kita lakukan debug terlebih dahulu dengan perintah debugnya di DHCP Server

R1#debug ip dhcp server events
R1#debug ip dhc ser packet detail

lalu di host kita cek dengan caranya bisa dengan shut no shut di intrface atau bisa menggunakan perintah “release dhcp fa0/0” dan dilanjutkan dengan perintah “renew dhcp fa0/0”

*Mar 1 02:22:35.887: DHCPD: Sending notification of DISCOVER:
*Mar 1 02:22:35.887: DHCPD: htype 1 chaddr c001.0e10.0000
*Mar 1 02:22:35.887: DHCPD: remote id 020a0000c0a80a0100000000
*Mar 1 02:22:35.887: DHCPD: circuit id 00000000
*Mar 1 02:22:35.887: DHCPD: Seeing if there is an internally specified pool class:
*Mar 1 02:22:35.891: DHCPD: htype 1 chaddr c001.0e10.0000
*Mar 1 02:22:35.891: DHCPD: remote id 020a0000c0a80a0100000000
*Mar 1 02:22:35.891: DHCPD: circuit id 00000000
*Mar 1 02:22:35.891: DHCPD: there is no address pool for 192.168.10.1.

cek IP di R2

R2#sh ip int fa0/0 | i address
Internet address will be negotiated using DHCP
Broadcast address is 255.255.255.255
Helper address is not set
Network address translation is disabled
R2#

ternyata masih belum dapat alamat IP di R2 dan proses debug terlihat R1 sudah bisa membaca mac-address host R2 tetapi R2 masih belum mendapatkan alamat IP juga dari DHCP Server.. hhhmmmmmm…..

setelah mencari ke beberapa tutorial ternyata perintah hardware-address di DHCP pool berfungsi untuk membagikan alamat IP bagi host yang menggunakan BOOTP, dan kita harus menggantinya karena host kita menggunakan DHCP, karena BOOTP biasa digunakan untuk diskless workstation, mari kita rubah DHCP pool dengan menggunakan “iketan IP” yang bisa mendukung untuk host yang menggunakan protokol DHCP yaitu dengan perintah client-identifier , berikut konfignya

R1(config)#ip dhcp pool POLBP
R1(dhcp-config)#no hardware-address
R1(dhcp-config)#client-identifier 01c0.010e.1000.00

sesudah perintah client-identifier jangan lupa di tambahkan 01 yang maksudnya media type berupa ethernet, kita lihat hasilnya dan jangan lupa di debug yaaa

*Mar 1 02:37:48.799: DHCPD: Sending notification of DISCOVER:
*Mar 1 02:37:48.799: DHCPD: htype 1 chaddr c001.0e10.0000
*Mar 1 02:37:48.799: DHCPD: remote id 020a0000c0a80a0100000000
*Mar 1 02:37:48.799: DHCPD: circuit id 00000000
*Mar 1 02:37:48.799: DHCPD: Seeing if there is an internally specified pool class:
*Mar 1 02:37:48.803: DHCPD: htype 1 chaddr c001.0e10.0000
*Mar 1 02:37:48.803: DHCPD: remote id 020a0000c0a80a0100000000
*Mar 1 02:37:48.803: DHCPD: circuit id 00000000
*Mar 1 02:37:48.831: DHCPD: Sending notification of ASSIGNMENT:
*Mar 1 02:37:48.835: DHCPD: address 192.168.10.2 mask 255.255.255.0

terlihat di debug alamat telah di berikan (assignment) di host sebenarnya tidak perlu di reset interface

R2(config-if)#do sh ip int fa0/0 | i add
Internet address is 192.168.10.2/24
Broadcast address is 255.255.255.255
Helper address is not set
Network address translation is disabled
R2(config-if)#

selesai lab DHCP kita, semoga bermanfaat

 

Salam,

Danu Wiyoto

 

Leave a comment

Your email address will not be published. Required fields are marked *

seventeen + ten =